Minerva: browser not compatible error

Tags faculty staff

​Students should use 32-bit Internet Explorer when using Minerva.  If they get any errors, try enabling compatibility view.

For additional support, please contact the Technology Service Desk.

Details

Article ID: 26802
Created
Thu 3/9/17 3:25 PM
Modified
Thu 7/26/18 10:59 AM